본문 바로가기
  • Welcome.
:: Network 🚩/Cisco Packet Tracer

[CISCO1]_#18_[port address translation, PAT, 라우터에의 SSH, 스위치에의 SSH, FTP, #do sh int]

by EunBird 2021. 8. 11.

<PAT> (port address translation) 


Router(config)#
Router(config)#ip nat pool korea 1.1.12.1 1.1.12.1 net 255.255.255.0  // 공인 ip를 하나만 만듬. ...(1)
Router(config)#
Router(config)#access-list 1 permit 192.168.10.0 0.0.0.255  // 사적 ip pool을 만듬.  ...(2)
Router(config)#
Router(config)#ip nat inside source list 1 pool koera overload // 공인 <--> 사설을 매핑 시킴. ...(3)
Router(config)#


Router(config)#interface fastEthernet 0/0
Router(config-if)#ip nat inside 
Router(config-if)#ex
Router(config)#
Router(config)#interface serial 0/0/0
Router(config-if)#ip nat outside 

 

 



< SSH >

 

Router(config)#username korea password 1234  // username(korea)과 password를 설정. ...(1)

Router(config)#
Router(config)#ip domain-name cisco.co.kr   // domain-name 설정. ...(2)
Router(config)#
Router(config)#crypto key generate ?
   rsa  Generate RSA keys
Router(config)#crypto key generate  rsa 

// rsa 형식으로 키를 만들기 전에 hostname을 기본형이 아닌 다른형태로 바꿔야 한다.(rsa는 domain-name과 hostname을 참고하여 key를 만들기 때문.)
% Please define a hostname other than Router.
Router(config)#
Router(config)#hostname R1  ...(3)
R1(config)#
R1(config)#crypto key generate  rsa  // rsa형식 키 설정.  ...(4)
The name for the keys will be: R1.cisco.co.kr
Choose the size of the key modulus in the range of 360 to 2048 for your
  General Purpose Keys. Choosing a key modulus greater than 512 may take
  a few minutes.

How many bits in the modulus [512]: 1024  // 몇비트로 설정할것인가?  ...(5)
% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]

R1(config)#
*Mar 1 0:5:4.933: %SSH-5-ENABLED: SSH 1.99 has been enabled
R1(config)#

R1(config)#line vty 0 4   // // 가상머신으로 5명 접속허용.   ...(6)
R1(config-line)#
R1(config-line)#transport input ?
  all     All protocols
  none    No protocols
  ssh     TCP/IP SSH protocol
  telnet  TCP/IP Telnet protocol

R1(config-line)#transport input ssh  ...(7)
R1(config-line)#
R1(config-line)#login local    // 로그인할때 username 과 password 를 물어보아라.  ...(8)

 

pc의 cmd에서 " ssh -l korea 192.168.10.1  "


 

 

< 스위치에서의 ssh접속 설정 >

 


Switch(config)#username korea pass 1234  // username(korea)과 password를 설정. ...(1)
Switch(config)#
Switch(config)#hostname SW1   // hostname 변경. ...(2)
SW1(config)#
SW1(config)#ip domain-name cisco.co.kr   // domain-name 설정. ...(3)
SW1(config)#
SW1(config)#crypto key generate rsa      // rsa암호화 설정.  ...(4)
  The name for the keys will be: SW1.cisco.co.kr
  Choose the size of the key modulus in the range of 360 to 2048 for your
  General Purpose Keys. Choosing a key modulus greater than 512 may take
  a few minutes.

How many bits in the modulus [512]: 1024   // 1024로 설정.  ...(5)
% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]

SW1(config)#
*Mar 1 0:14:49.933: %SSH-5-ENABLED: SSH 1.99 has been enabled
SW1(config)#
SW1(config)#line vty 0 4   // 가상머신으로 5명 접속허용.  ...(6)
SW1(config-line)#
SW1(config-line)#transport input ssh   // ...()
SW1(config-line)#
SW1(config-line)#login local  // 로그인할때 username 과 password 를 물어보아라.  ...(7)
SW1(config-line)#

SW1(config-line)#exit
SW1(config)#
SW1(config)#
SW1(config)#in
SW1(config)#interface vlan 1    // 스위치는 ip가 없으므로 vlan에 설정.
SW1(config-if)#
SW1(config-if)#ip address 192.168.10.100 255.255.255.0  
SW1(config-if)#ex
SW1(config)#
SW1(config)#ip default-gateway 192.168.10.1  // 게이트웨이도 설정.

 

 

 

 


 


 

< FTP 를 통해 Server에 정보 저장하기/불러오기 >

먼저 server 에서 username과 password를 설정.


Router(config)#
Router(config)#ip ftp username test   // ftp username 설정.
Router(config)#ip ftp password 1234  // 해당 user의 password까지 설정.
Router(config)#
Router(config)#do copy run ftp:    // running-config에서 ftp로
Address or name of remote host []? 192.168.20.100  // server의 ip
Destination filename [Router-confg]?  // 대괄호는 그냥 엔터해도 됨.

Writing running-config...
[OK - 857 bytes]

857 bytes copied in 0.02 secs (42000 bytes/sec)
Router(config)#
-->running-config에서 ftp서버로 저장.

Router-config 라는 이름으로 저장되었음을 알 수 있다.


ㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡ

아래는 ftp서버에서 running-config로 불러오기.

 



Router(config)#do copy ftp: run  // ftp에서 runninf-config로.
Address or name of remote host []? 192.168.20.100  // server ip 입력.
Source filename []? Router-config   // 불러올 파일 이름 입력.
Destination filename [running-config]?    // enter.

Accessing ftp://192.168.20.100/Router-config...
%Error ftp:///Router-config (No such file or directory Or Permission denied)

Router(config)#

 




Router(config)#do sh int  // interface에 대한 정보확인 가능.

Serial0/0/0의 encapsulation이 HDLC임을 확인 가능.
Serial0/0/0 의 Encapsulation이 PPP로 설정되어있음.

 

 

Serial0/0/1의 enacapsulation이 HDLC로 설정되어있음.

ㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡㅡ

 

 

 

 

Router의 Ethernet이 남는다면 Serial로 잇지않고 Ethernet으로 이을 수 도 있다.

728x90

댓글